注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

c.pass 的博客

众里寻他千百度,蓦然回首,那人却在,灯火阑珊处。

 
 
 

日志

 
 

AS5300语音网关配置  

2010-05-28 13:44:49|  分类: 默认分类 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |


as5300-1#sh run
Building configuration...
Current configuration : 4905 bytes
!
version 12.2
no service pad
no service timestamps debug uptime
no service timestamps log uptime
service password-encryption
no service dhcp
!
hostname as5300-1
!
no logging rate-limit
enable secret 5 $1$3Br4$N9tSriHsHW4vg/A4O3kdL/
enable password 7 070C2D494F1B0900161E
!
username jtnet password 7 04511F39302F495A
!
!
resource-pool disable
resource-pool call treatment resource channel-not-available
!
call rsvp-sync // RSVP呼叫同步
!
call progress tone country china //系统时间为第八时区北京时间
clock timezone china 8
clock calendar-valid
calltracker enable
ip subnet-zero
no ip source-route
no ip domain-lookup
!
isdn switch-type primary-net5 //ISDN交换机类型
isdn voice-call-failure 0 //ISDN语音呼叫失败无效
isdn alert-end-to-end
voice call send-alert //语音呼叫发送报警
voice rtp send-recv //语音实时发送与接收
!
voice service voip //VOIP语音服务
!
voice class codec 88 //语音编解码分类
codec preference 1 g729br8 //1级优先权编解码方式
codec preference 2 g729r8 bytes 50 //2级优先权编解码方式
codec preference 3 g711alaw //3级优先权编解码方式
codec preference 4 g723ar53 //4级优先权编解码方式
codec preference 5 g723ar63 bytes 144 //5级优先权编解码方式
codec preference 6 g723r53 //6级优先权编解码方式
codec preference 7 g723r63 bytes 120 //7级优先权编解码方式
codec preference 8 g726r16 //8级优先权编解码方式
codec preference 9 g726r24 //9级优先权编解码方式
codec preference 10 g726r32 //10级优先权编解码方式
codec preference 11 g728 //11级优先权编解码方式
!
!
!
!
!
fax interface-type modem //传真机调制解调器接口类型
mta receive maximum-recipients 1 //报文传送代理接收最大收件人为1
dial-control-mib retain-timer 60
dial-control-mib max-size 1200
!
controller E1 0 //配置 E1语音卡0
framing NO-CRC4 //编帧方式:NO-CRC4 编码方式(linecode):默认的HDB3
clock source line primary
pri-group timeslots 1-31 //把PRI接口划分为31个信道,其中第十六个信道(逻辑端口s0:15)是管理信道
!
controller E1 1
framing NO-CRC4
clock source line secondary 1
pri-group timeslots 1-31
!
controller E1 2
framing NO-CRC4
clock source line secondary 2
pri-group timeslots 1-31
!
controller E1 3
shutdown
framing NO-CRC4
clock source line secondary 3
pri-group timeslots 1-31
!
translation-rule 101 //转换规则 101
Rule 0 any 55514400
!
translation-rule 102 //转换规则 102
Rule 0 any 55514401
!
translation-rule 103
Rule 0 any 55514403
!
translation-rule 104
Rule 0 any 88588858
!
translation-rule 112
!
!
!
interface Loopback0
no ip address
!
interface Ethernet0
no ip address
no ip route-cache
no ip mroute-cache
shutdown
no cdp enable
!
interface Serial0
no ip address
no ip route-cache
no ip mroute-cache
shutdown
no fair-queue
clockrate 2015232
no cdp enable
!
interface Serial1
no ip address
no ip route-cache
no ip mroute-cache
shutdown
no fair-queue
clockrate 2015232
no cdp enable
!
interface Serial2
no ip address
no ip route-cache
no ip mroute-cache
shutdown
no fair-queue
clockrate 2015232
no cdp enable
!
interface Serial3
no ip address
no ip route-cache
no ip mroute-cache
shutdown
no fair-queue
clockrate 2015232
no cdp enable
!
interface Serial0:15
no ip address
isdn switch-type primary-net5
no fair-queue
no cdp enable
!
interface Serial1:15
no ip address
isdn switch-type primary-net5
no fair-queue
no cdp enable
!
interface Serial2:15
no ip address
isdn switch-type primary-net5
no fair-queue
no cdp enable
!
interface Serial3:15
no ip address
isdn switch-type primary-net5
no fair-queue
no cdp enable
!
interface FastEthernet0 //快速以太网管理端口接口配置
ip address xxx.xxx.xxx.xxx 255.255.255.248 //配置快速以太网网卡的IP地址和子网掩码
no ip route-cache
no ip mroute-cache
duplex full
speed 100
no cdp enable
h323-gateway voip interface //h323网关VOIP连接
h323-gateway voip h323-id AS5300 //h323网关VOIP连接h323ID为AS5300
!
ip classless
ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx
ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx
no ip http server
ip pim bidir-enable
!
no logging trap
no cdp run
!
!
voice-port 0:D //配置模拟语音端口
input gain 5
output attenuation 11 //输出衰减为11
echo-cancel coverage 32 //回音抵消覆盖率为32
cptone CN
!
voice-port 1:D
input gain -5
output attenuation 11
echo-cancel coverage 32
cptone CN
!
voice-port 2:D
input gain 5
output attenuation 11
echo-cancel coverage 32
cptone CN
!
voice-port 3:D
input gain 5
output attenuation 11
echo-cancel coverage 32
cptone CN
!
dial-peer voice 427 pots //定义拨号对等体到语音物理端口
destination-pattern 88770081T //为拨号对等体分配电话号码
translate-outgoing calling 101 //转换出局主叫为1
port 2:D //定义语音端口
prefix 0081
!
dial-peer voice 428 pots
destination-pattern 55600081T
translate-outgoing calling 103
port 2:D
prefix 0081
!
dial-peer voice 432 pots
destination-pattern 55600081T
translate-outgoing calling 102
port 1:D
prefix 0081
!
dial-peer voice 429 pots
destination-pattern 88770T
port 2:D
prefix 0
!
dial-peer voice 500 pots
destination-pattern 67890063T
port 0:D
prefix 0063
!
dial-peer voice 510 pots
destination-pattern 55990063T
translate-outgoing calling 101
port 2:D
prefix 0063
!
dial-peer voice 511 pots
destination-pattern 559900639T
translate-outgoing calling 101
port 1:D
prefix 00639
!
dial-peer voice 513 pots
destination-pattern 5580008869T
translate-outgoing calling 101
prefix 008869
!
dial-peer voice 600 pots
destination-pattern 17811T
port 0:D
prefix 00
!
dial-peer voice 601 pots
destination-pattern 17811T
port 1:D
prefix 00
!
gateway
!
alias exec VA show call act voi br
!
line con 0
exec-timeout 5 0
line aux 0
exec-timeout 5 0
line vty 0 4
exec-timeout 5 0
password 7 030555130F0174111c
login
!
scheduler interval 1000
end
as5300-1#


原文摘自:

http://loutsx.blog.163.com/blog/static/161992087201031032248655/
  评论这张
 
阅读(303)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017