注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

c.pass 的博客

众里寻他千百度,蓦然回首,那人却在,灯火阑珊处。

 
 
 

日志

 
 

Cisco as5300配置详解  

2010-05-28 13:56:05|  分类: 默认分类 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |



Cisco as5300配置详解(一)

version 12.2                                                       //自引导程序版本号

service timestamps debug datetime localtime     //设定Debug跟踪日志显示系统时间

service timestamps log datetime localtime          //设定看Log时显示系统时间

service password-encryption      //口令加密

!

hostname Router                       //设置系统网络名为Router

!

aaa new-model                         // 为了管理四组互相独立的帐号, 启用AAA模式

aaa authentication login no_rad local    //进行login认证,若radius server未找到从本地数据库内查找

aaa authorization exec h323 group radius     //授权检测

aaa accounting connection h323 stop-only group radius     //计帐检测

enable secret 5 $1$j5Q4$DZZ2i9v0pISU3RKSKzF8o     //启用特权模式口令验证

enable password 7 13000F1B1F      //特权模式口令

!

username test1 password 7 001403120157        //第一组拔号用户使用的帐号和密码

username test2 password 7 02110D55180901   //第二组拔号用户使用的帐号和密码

username test3 password 7 051F0E063359       //第三组拔号用户使用的帐号和密码

username test4 password 7 020A1E150C01       //第四组拔号用户使用的帐号和密码

!

!

resource-pool disable                         //资源池无效

resource-pool call treatment resource channel-not-available               //资源池呼叫处理资源信道无效

!

call rsvp-sync                    // RSVP呼叫同步

clock timezone Beijing 8    //系统时间为第八时区北京时间

ip subnet-zero                   //允许0子网

no ip source-route             //不根据源路由头的选择处理包

no ip domain-lookup          //不打开IP域名服务系统主机转换

!

no ip bootp server

isdn switch-type primary-net5             //ISDN交换机类型

isdn voice-call-failure 0                     //ISDN语音呼叫失败无效

voice call send-alert                      //语音呼叫发送报警

voice call convert-discpi-to-prog      

voice rtp send-recv               //语音实时发送与接收

!

voice service voip                         #VOIP语音服务

h323 h245 tunnel defer                #h323、h245管道延迟

!

voice class codec 88                                        //语音编解码分类

codec preference 1 g729r8                              //1级优先权编解码方式

codec preference 2 g729br8                            //2级优先权编解码方式

codec preference 3 g723r63                            //3级优先权编解码方式

codec preference 4 gsmefr                               //4级优先权编解码方式

codec preference 5 g711alaw                           //5级优先权编解码方式

codec preference 6 g723ar63 bytes 144          //6级优先权编解码方式

codec preference 7 g711ulaw                           //7级优先权编解码方式

!

!

!

!

!

fax interface-type modem                    // 传真机调制解调器接口类型

mta receive maximum-recipients 1     //报文传送代理接收最大收件人为1

!

controller E1 0                   //配置 E1语音卡1

framing NO-CRC4             //编帧方式:NO-CRC4 编码方式(linecode):默认的HDB3

clock source line primary

pri-group timeslots 1-31     //把PRI接口划分为31个信道,其中第十六个信道(逻辑端口s0:15)是管理信道

!

controller E1 1                   //配置 E1语音卡2

framing NO-CRC4             //编帧方式:NO-CRC4 编码方式(linecode):默认的HDB3

clock source line secondary 1

pri-group timeslots 1-31         //把PRI接口划分为31个信道,其中第十六个信道(逻辑端口s0:15)是管理信道

!

controller E1 2                       //配置 E1语音卡3

clock source line secondary 2

!

controller E1 3                       //配置 E1语音卡4

clock source line secondary 3

!

controller E1 4                       //配置 E1语音卡5

clock source line secondary 4

!

controller E1 5                       //配置 E1语音卡6

clock source line secondary 5

!

controller E1 6                       //配置 E1语音卡7

clock source line secondary 6

!

controller E1 7                       //配置 E1语音卡8

clock source line secondary 7

!

gw-accounting h323 vsa

gw-accounting voip

 

 

 


Cisco as5300配置详解(二)

translation-rule 1                 //转换规则 1

Rule 1 any 0017991

!

translation-rule 2                 //转换规则 2

Rule 0 99591860 9959186

!      

translation-rule 3                 //转换规则 3

Rule 0 995918605911 59181

Rule 1 995918605912 59122

Rule 2 995918605913 59183

Rule 3 995918605914 59124

Rule 4 995918605915 59185

Rule 5 995918605916 59126

Rule 6 995918605917 59187

Rule 7 995918605918 59128

Rule 8 995918605919 59189

!

translation-rule 4                 //转换规则 4

Rule 0 992628605911 59181

Rule 1 992628605912 59122

Rule 2 992628605913 59183

Rule 3 992628605914 59124

Rule 4 992628605915 59185

Rule 5 992628605916 59126

Rule 6 992628605917 59187

Rule 7 992628605918 59128

Rule 8 992628605919 59189

!

!

!

interface Ethernet0               //第一个网卡接口配置

ip address 51.235.70.91 255.255.255.224 //第一个网卡的IP和子网掩码

keepalive 60                     //保持活动时间60时间

no cdp enable                       //CDP不可用

!

interface Serial0               //串口0接口配置

no ip address                   //没有分配IP地址

shutdown                         //接口为关闭状态

no fair-queue                   //没有流线队列

clockrate 2015232           //时钟频率

no cdp enable                   //CDP不可用

!

interface Serial1                 //串口1接口配置

no ip address                    //没有分配IP地址

shutdown                           //接口为关闭状态

no fair-queue                     //没有流线队列

clockrate 2015232             //时钟频率

no cdp enable                   //CDP不可用

!

interface Serial2                 //串口2接口配置

no ip address                      //没有分配IP地址

shutdown                            //接口为关闭状态

no fair-queue                      //没有流线队列

clockrate 2015232              //时钟频率

no cdp enable                     //CDP不可用

!

interface Serial3                 //串口3接口配置

no ip address                    //没有分配IP地址

shutdown                          //接口为关闭状态

no fair-queue                     //没有流线队列

clockrate 2015232             //时钟频率

no cdp enable                   //CDP不可用

!

interface Serial0:15               //串口0管理端口接口配置

no ip address                       //没有分配IP地址

ip mroute-cache                    //IP多路由缓存

no snmp trap link-status                      //无SNMP俘获连接状态

isdn switch-type primary-net5             //ISDN交换机类型

isdn overlap-receiving T302 3000

isdn incoming-voice modem               //ISDN入局语音调制解调器

isdn map address .* plan isdn type national          //ISDN变换地址全国性ISDN计划类型

isdn T309-enable

isdn T310 60000

isdn send-alerting                        //ISDN发送信号

isdn sending-complete               //ISDN发送信号完成

fair-queue 64 256 0                   //流线队列

no cdp enable                          //CDP不可用

!

interface Serial1:15           //串口1管理端口接口配置

no ip address                   //没有分配IP地址

ip mroute-cache               //IP多路由缓存

no snmp trap link-status                      //无SNMP俘获连接状态

isdn switch-type primary-net5             //ISDN交换机类型

isdn overlap-receiving T302 3000

isdn incoming-voice modem               //ISDN入局语音调制解调器

isdn map address .* plan isdn type national //ISDN变换地址全国性ISDN计划类型

isdn calling-number 0017991             //ISDN呼叫编号

isdn T309-enable

 


Cisco as5300配置详解(三)

isdn T203 30000

isdn T310 60000

isdn send-alerting               //ISDN发送信号

isdn sending-complete               //ISDN发送信号完成

fair-queue 64 256 0                   //流线队列

no cdp enable

!

interface FastEthernet0               //第一个快速以太网网卡接口配置

ip address 51.235.77.144 255.255.255.192 //配置第一个快速以太网网卡的IP地址和子网掩码

keepalive 60                     //保持活动时间60时间

duplex full                       //全双工通信

speed auto                     //自动加速

h323-gateway voip interface               //h323网关VOIP连接

h323-gateway voip id cisco ipaddr 110.21.117.55 1719   //h323网关VOIP连接ID和IP地址

h323-gateway voip h323-id as5300gw         //h323网关VOIP连接h323ID为AS5300gw

!

ip classless

ip route 0.0.0.0 0.0.0.0 51.235.70.65            

ip route 0.0.0.0 0.0.0.0 51.235.77.129          

no ip http server                 //无http服务器

ip pim bidir-enable

!

logging 110.21.117.58                 //日记记录服务器的IP地址

tftp-server flash:c5300-is-mz.122-7c.bin    

snmp-server community pptel RO

snmp-server community syscom RW 1

!

radius-server host 110.21.117.58 auth-port 1645 acct-port 1646     //radius服务器IP、验证端口和访问端口

radius-server host 110.21.117.57 auth-port 1645 acct-port 1646     //radius服务器IP、验证端口和访问端口

radius-server retransmit 3             //radius服务器中继站数为3

radius-server timeout 6               //radius服务器超时时间为6秒

radius-server key 7 120A1C04110401

radius-server vsa send accounting

!

voice-port 0:D           //配置模拟语音端口

output attenuation 4         //输出衰减为4

echo-cancel coverage 32   //回音抵消覆盖率为32

cptone CN

timeouts initial 5       //超时初始设定为5秒

timeouts interdigit 3         //中间超时设定为3秒

bearer-cap Speech         //集合信道语音

!

voice-port 1:D           //配置模拟语音端口

output attenuation 4         //输出衰减为4

echo-cancel coverage 32   //回音抵消覆盖率为32

cptone CN

timeouts initial 5       //超时初始设定为5秒

timeouts interdigit 3         //中间超时设定为3秒

bearer-cap Speech         //集合信道语音

!

dial-peer voice 20000 pots             //定义拨号对等体到语音物理端口

max-conn 15                   //最多连接数为15

destination-pattern 9755T       //为拨号对等体分配电话号码

progress_ind setup enable 3           //启用进展提示设置

progress_ind alert enable 8           //启用进展提示报警

translate-outgoing calling 1           //转换出局主叫为1

port 1:D                             //定义语音端口

!

dial-peer voice 1 pots                 //定义拨号对等体到语音物理端口

max-conn 4                     //最多连接数为4

destination-pattern 1230T       //为拨号对等体分配电话号码

progress_ind setup enable 3           //启用进展提示设置

progress_ind alert enable 8           //启用进展提示报警

translate-outgoing calling 1           //转换出局主叫为1

direct-inward-dial               //直接内部拨号

port 1:D                         //定义语音端口

!

dial-peer voice 70000 pots             //定义拨号对等体到语音物理端口

destination-pattern 9926286T         //为拨号对等体分配电话号码

progress_ind setup enable 3           //启用进展提示设置

progress_ind alert enable 8           //启用进展提示报警

translate-outgoing calling 1           //转换出局主叫为1

translate-outgoing called 3           //转换出局被叫为3

direct-inward-dial               //直接内部拨号

port 1:D                         //定义语音端口

!

dial-peer voice 70001 pots             //定义拨号对等体到语音物理端口

destination-pattern 9959186T         //为拨号对等体分配电话号码

progress_ind setup enable 3           //启用进展提示设置

progress_ind alert enable 8           //启用进展提示报警

translate-outgoing calling 1           //转换出局主叫为1

translate-outgoing called 3           //转换出局被叫为3

direct-inward-dial               //直接内部拨号

port 1:D                         //定义语音端口

!

 

Cisco as5300配置详解(四)

dial-peer voice 70100 pots             //定义拨号对等体到语音物理端口

destination-pattern 9926286T         //为拨号对等体分配电话号码

progress_ind setup enable 3           //启用进展提示设置

progress_ind alert enable 8           //启用进展提示报警

translate-outgoing calling 1           //转换出局主叫为1

translate-outgoing called 4           //转换出局被叫为4

direct-inward-dial               //直接内部拨号

port 0:D                         //定义语音端口

prefix    99  /此为加上前缀
!
注意:dial-peer 中pots和voip的destination-pattern 有着不同的意义,pots中定义的prefix在送到中继的时候后自动吃掉,如果要加perfix则必须用perfix命令,而voip中则会和号码一起送出去,在53中是无法做的变换。


dial-peer voice 70101 pots           //定义拨号对等体到语音物理端口

destination-pattern 9959186T      //为拨号对等体分配电话号码

progress_ind setup enable 3        //启用进展提示设置

progress_ind alert enable 8          //启用进展提示报警

translate-outgoing calling 1          //转换出局主叫为1

translate-outgoing called 3           //转换出局被叫为3

direct-inward-dial                          //直接内部拨号

port 0:D                                        //定义语音端口

!

dial-peer voice 70102 pots             //定义拨号对等体到语音物理端口

destination-pattern 9982786T         //为拨号对等体分配电话号码

progress_ind setup enable 3           //启用进展提示设置

progress_ind alert enable 8           //启用进展提示报警

translate-outgoing calling 1           //转换出局主叫为1

direct-inward-dial               //直接内部拨号

port 1:D                             //定义语音端口

!

dial-peer voice 32323 pots         //定义拨号对等体到语音物理端口

destination-pattern 26586T       //为拨号对等体分配电话号码

port 1:D                                     //定义语音端口

!

dial-peer voice 148911 pots           //定义拨号对等体到语音物理端口

destination-pattern 22290T            //为拨号对等体分配电话号码

progress_ind setup enable 3         //启用进展提示设置

progress_ind alert enable 8           //启用进展提示报警

translate-outgoing calling 1            //转换出局主叫为1

direct-inward-dial               //直接内部拨号

port 0:D                            //定义语音端口

!

dial-peer voice 301886 pots           //定义拨号对等体到语音物理端口

max-conn 2                                    //最大连接数为2

destination-pattern 301886T       //为拨号对等体分配电话号码

progress_ind setup enable 3      //启用进展提示设置

progress_ind alert enable 8       //启用进展提示报警

port 1:D                                      //定义语音端口

!

gateway

!

!

line con 0               //设定登陆        

line aux 0              

line vty 0 4             //允许用Telnet        

exec-timeout 30 0

password 7 011B070D43020700

!

ntp clock-period 17179436                

ntp server 192.5.41.41                    

ntp server 102.112.0.38                  

ntp server 102.108.158.139                

ntp server 192.5.41.209 prefer                  

end


原文摘自:http://loutsx.blog.163.com/blog/static/161992087201031032231263/

  评论这张
 
阅读(479)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018