注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

c.pass 的博客

众里寻他千百度,蓦然回首,那人却在,灯火阑珊处。

 
 
 

日志

 
 

Cisco 3640的VOIP配置  

2010-07-11 15:23:46|  分类: 默认分类 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

下面是Cisco 3640的VOIP配置,结构是台北和上海两地做VOIP,后接阿尔卡特的PBX,里面有很多需要注意的地方。
台北配置代码:

Taipei#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime(设定Debug跟踪日志显示其时间)
service timestamps log uptime(设定看Log时显示其时间)
no service password-encryption(口令不加密)
!
hostname Taipei(主机名)
!
enable secret 5 $1$R.66$z.BUjhNsJcIr8KCcS9uxG.
!
!
!
!
!
voice-card 1(定义语音卡1)
!
voice-card 3(定义语音卡3)
!
ip subnet-zero
no ip domain-lookup
!
isdn voice-call-failure 0
!
!
!
!
controller E1 1/0(配置 E1语音卡)
framing NO-CRC4
ds0-group 0 timeslots 1-15,17-31 type e&m-wink-start(定义语音卡的类型为E&M卡)
cas-custom 0
!
controller E1 3/0(配置 E1语音卡)
framing NO-CRC4
ds0-group 0 timeslots 1-15,17-31 type e&m-wink-start(定义语音卡的类型为E&M卡)
cas-custom 0
!
!
!
interface BRI0/0
no ip address
no ip directed-broadcast
shutdown
isdn guard-timer 0 on-expiry accept
!
interface FastEthernet0/0
no ip address
no ip directed-broadcast
shutdown
duplex auto
speed auto
!
   interface Serial0/0
description "Link to MainLand_ShangHai by NCIC lease line"
ip address 192.168.1.1 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
no fair-queue
!
interface Serial0/1
no ip address
no ip directed-broadcast
shutdown
clockrate 2000000
!
ip classless
no ip http server
!
!
voice-port 1/0:0(配置模拟语音端口)
compand-type a-law
!
voice-port 3/0:0(配置模拟语音端口)
compand-type a-law
!
dial-peer voice 1 voip (定义拨号对等体到语音)
destination-pattern +445...(为拨号对等体分配电话号码,其中.为通配符)
session target ipv4:192.168.1.2(定义Voip路由,为对端的IP地址)
req-qos guaranteed-delay (语音数据流RVSP的保证,其中Guaranteed-dealy可用于保证整个网络的延时)
ip precedence 5(IP优先级,5为关键)
!
dial-peer voice 2 pots(定义拨号对等体到语音物理端口)
destination-pattern +3...(定义电话话码以3开头的)
port 1/0:0(定义语音端口)
!
dial-peer voice 3 pots(定义拨号对等体到语音物理端口)
destination-pattern +3...(定义电话话码以3开头的)
port 3/0:0(定义语音端口)
!
!
line con 0(设定登陆)
transport input none
line aux 0
line vty 0 4(允许用Telnet)
password cisco(口令为Cisco)
login
!
end
Taipei#

 

上海一方的3640配置代码:

ShangHai#sh run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname ShangHai
!
enable secret 5 $1$dB/c$tnrMU9IxFCJdix5ssHAdH/
!
!
!
!
!
voice-card 1
!
voice-card 2
!
ip subnet-zero
no ip domain-lookup
!
isdn voice-call-failure 0
!
!
!
!
controller E1 1/0
framing NO-CRC4
ds0-group 0 timeslots 1-15,17-31 type e&m-immediate-start
cas-custom 0
!
   controller E1 2/0
framing N
ds0-group 0 timeslots 1-15,17-31 type e&m-immediate-start
cas-custom 0
!
!
!
interface BRI0/0
no ip address
no ip directed-broadcast
encapsulation ppp
isdn guard-timer 0 on-expiry accept
ppp multilink
!
interface FastEthernet0/0
no ip address
no ip directed-broadcast
shutdown
duplex auto
speed auto
!
interface Serial0/0
no ip address
no ip directed-broadcast
no ip mroute-cache
shutdown
no fair-queue
clockrate 2000000
!
interface Serial0/1
ip address 192.168.1.2 255.255.255.252
no ip directed-broadcast
!
ip classless
!
no ip http server
!
!
voice-port 1/0:0
compand-type a-law
!
voice-port 2/0:0
compand-type a-law
!
dial-peer voice 20 voip
destination-pattern +3...
session target ipv4:192.168.1.1
req-qos guaranteed-delay
ip precedence 5
!
dial-peer voice 10 pots
destination-pattern +448...
port 1/0:0
!
dial-peer voice 30 voip
destination-pattern +4...
session target ipv4:192.168.1.1
req-qos guaranteed-delay
ip precedence 5
!
dial-peer voice 40 pots
destination-pattern +449...
port 2/0:0
!
!
line con 0
transport input none
line aux 0
line vty 0 4
password cisco
login
!
end
ShangHai#

  评论这张
 
阅读(348)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017